Jump to content

Stax SRM007tA amp - diode burn due to high voltage


Recommended Posts

Dear All

Due to sudden voltage spike last night - my stax vaccume tube amp srm007TA diode burnt out.  Can you guide through the process to fix this issue?

I have attached the images below for reference.

Hopefully the PCB seems to be intact.  But i am not a expert and any advise is highly appreciated

Thank you

Stax amp_image 1.jpg

Stax amp image_2.jpg

Link to post
Share on other sites

https://www.head-fi.org/threads/stax-srm-007tii-amp-tube-rolling-bias-adjustment.653258/post-16389801

this person published half the schematic. This schematic is similar to, but not the same as your amp which has dc filaments.

you need to replace all the parts including the diodes and capacitors. the other high voltage caps don't look very good either.

and likely one or more of the tubes are bad.

Edited by kevin gilmore
Link to post
Share on other sites

Thanks so much Kevin for your response.  Would you suggest - its still feasible to source and replace all of them. From cost point of view - would it be a major overhaul.  I live in india and still searching for a Hi-tech service stores who can repair it.  Kindly advise.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...