Jump to content

jigster

Members
  • Posts

    18
  • Joined

  • Last visited

About jigster

  • Birthday 02/01/1973

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

jigster's Achievements

Member

Member (2/6)

10

Reputation

  1. Thanks for the offer Alex. However, I found an easier, intermittent solution. I opened up the enclosure and pulled more cable into the cup until the wires weren't visible anymore and secured it inside. Out of sight, out of mind. May just cut the excess at a later time if I needed to.
  2. Well, I guess that's also true, it would have looked much better and more pro. Anyway, just checked my picture again and with the headphone, its not a zip tie, its just the reflected part of the enclosure of cable entry point; ie, the cross section.
  3. To be fair, that's an APS cable I sent him to install but I guess he could have shortened the lead up to where the heatshrink ends. But to me its a minor no-no. I'm just glad I got the headphones, unlike my ugly experiences with a certain SPA-hole.
  4. Have to admit, the excitement and anticipation kind of fizzled out. But its always a great feeling to receive a package in the mail, especially on Mondays! Even more so, after the holidays.
  5. Mine arrived yesterday, running in as we speak. Left the Alessandros with Rhydon to mod and ship as a complete headphone. Didn't want to bother with exchanging the drivers. But then I would have a spare stock driver, oh well. Now people, give Rhydon some slack, he came through in the end. Haven't heard a stock MS2i before, think I may just go and audition a pair for comparison.
  6. Anyone know how I can remove the red support bars? Can seem to figure out how its removed. There seem to be 4 plastic screws holding them but the screws get damaged when you put a screwdriver to them and turn. Dang. Anyone opened/removed them before? Thanks.
  7. Think I found it on page 48 of the thread but the pictures (I assume that there were pictures) unfortunately aren't there anymore. http://www.head-case.org/forums/headphones/785-headcase-stax-thread-48.html
  8. In this thread? Hmm... need to spend some time reading then. Thanks, really useful stuff.
  9. Oh, didn't know that Sigma Pros utilized Lambda Sig drivers. Thanks for the heads up before I do something doofus. The Sigma and Sigma Pro have the same enclosure structure don't they? So all I need do is get my hands on a pair of really cheap 404 to mutilate?
  10. Yes yes yes dun I know it. Am frantically saving as much dosh as I can for the killer amp, which I suspect would be a serial killer of wallets and bank accounts.
  11. Thanks Birgir for re-affirming my queries, thought I had gotten a "faulty" pair, nonetheless, I'm disappointed with the sound. Time to look for a cheap 404 or Lambda Sig to mutilate.
  12. ooops sorry, made a mistake as my pal had pointed out to me that the Tabu is 80watts/channel not 30watts.
  13. My 10k+ K1K is sounding quite punchy in the bass dept though, was quite surprised by it as I was expecting the same results as my previous 7k+. Most of my mates agree that the bass was sufficiently impressive, not what they expected from reading about K1Ks. But then again for most of them, this was the 1st time they've heard a K1K.. duh. It was connected to a Gryphon Tabu (30 watts dual mono), which was quite nice.
  14. Woah... Just came across this thread, must have been blind all this while (though I did only just joined the Headcase community ). This project looks awesome! I'll would dearly love to get my hands on one of these monsters. Now I know where to put ALL my hard earned money.... This IS my wet dream!
×
×
  • Create New...