Jump to content
deepak

Koss ESP/950 electrostat thread

Recommended Posts

A simple question, is there a charge up issue when using the E/90?

Spritzer, can you tell me when and where this ESP950 I got from you was originally bought?

All these headphones are just a blur to me but I think I bought them about a year ago from Mapstec who had the recable work done.

Share this post


Link to post
Share on other sites
2. How do I explain the missing cable? I know it says "no questions asked" limited warrantee, but it's like, how do I know the drivers take a while to charge if there is no cable? Shouldn't I explain something like, "the old cable had a short so it was replaced last year with a Stax cable and adapter to use with the E90 which could not be returned with the ESP950".

It's really "no questions asked", mine didn't have any cable attached and the only thing I inserted in the box other than the headphones themselves (edit: I mean the whole package, not just the headphones) was a check. I got back a brand new set. Seriously, I think you worry too much about the situation, Koss customer service has a good reputation and they will just replace your phones. If it was a Singlepower amp, on the other hand... ;D

Edited by GPH

Share this post


Link to post
Share on other sites
It's really "no questions asked", mine didn't have any cable attached and the only thing I inserted in the box other than the headphones themselves (edit: I mean the whole package, not just the headphones) was a check. I got back a brand new set. Seriously, I think you worry too much about the situation, Koss customer service has a good reputation and they will just replace your phones. If it was a Singlepower amp, on the other hand... ;D

What did you tell them was wrong with it when you sent it in, since there was no cable attached?

Poor Canadian have to pay $7.00

Share this post


Link to post
Share on other sites
What did you tell them was wrong with it when you sent it in, since there was no cable attached?

Poor Canadian have to pay $7.00

I explained my problem with my pair but they did not ask any questions (just like their site says).

Share this post


Link to post
Share on other sites
What did you tell them was wrong with it when you sent it in, since there was no cable attached?

Nothing. I thought it was better to do that than write something like "I desoldered the cable and was too lazy to put it back in".

Share this post


Link to post
Share on other sites
"Your stock amp sucks so I've taken the liberty of recabling it so I can use it with a KGSS" :D

True dat, I only have the E/90 right now and I find the ESP950 brightish and slightly harsh with weird bass that doesn't extend very low. I prefer them to the HD650 though, even in this state. I had forgotten how much I like the very open and detailed sound of stats, though I probably didn't give a fair chance to the Senns with a Pico. I'm waiting for the cheap bastard DIY electrostatic amp to materialize, but I could buy a used Stax amp if I see one along the way.

Share this post


Link to post
Share on other sites
mother fuck. The squeal is back and the headphones have been in my hands for maybe 5 hours

I think I've heard something resembling a small squeal the other night for what it's worth, but nothing compared to my old pair. It's still worrying though, there must be some solution to fix this.

Share this post


Link to post
Share on other sites

Worse with the stax SRM-1/MK2. Which is odd since the bias voltage is lower.

Only in the right channel.

Edited by Dreadhead

Share this post


Link to post
Share on other sites

Well it turns out that Koss repaired my headphones not replaced them. The pick ticket says to "replace - H,B, Assembly, Cushion Adhesive Ring, Cover foam, and serial label". I find the replacement of the serial label the most interesting, since they didn't replace the The driver came back more screwed as before because the little mesh/plastic ring was broken.

Sent to Koss:

Hello Shirley,

I picked up my unit from my mailbox today (I have been out of town) and on first listen the right driver is still damaged and squealing. The driver also felt loose so I took a look inside the unit and the plastic ring for that held the driver in place was broken and the driver just fell out. I attempted to put the driver together and somewhat succeded but the squeal is still there.I hope this is not what Koss usually calls "repaired".

Should I send the unit back in and wait another couple weeks for a fully functional replacement pair? Is it possible to just have the drivers and y cable sent to me? I would rather not have to wait through the whole process all over again. If I must I must.

Regards,

etc...

We'll see if I hear anything. I doubt I will and I will now have to send my glued together unit back to them and wait again.

Share this post


Link to post
Share on other sites

The squeal can be any number of things but some debris stuck inside the driver could be the reason. The dustcover on the front of the driver looks like an afterthought and the back dust cover is of the same caliber as the Jade. :palm:

Share this post


Link to post
Share on other sites
What were they thinking? That the squeal was air pressure? Or friction?

I don't know but my new head band and cosmetic repairs should fix it all! :palm:

I sent a long letter telling them that the squeal was in the right driver. Maybe I should push a pencil through the damn thing and then send it in.

Share this post


Link to post
Share on other sites

Well their customer support supposedly sent me a UPS label for me to ship them back. Now after I've had to glue stuff together to get it not to squeal they will likely not want to honor the warranty but we shall see.

The dance continues....

Share this post


Link to post
Share on other sites

Well, with the ESP950 unplugged for 26 hours it only took 30 seconds to charge up tonight, with the vague possibility that the left driver might be taking up to 60-90 seconds to get that last 1dB of imbalance caught up. They sound really good, and I think we'll just wait a while before sending them in for this minor issue. If they are used every day it is a non-issue.

Share this post


Link to post
Share on other sites

After sending in just the amp and headphones, without cables, they sent me back the amp and new headphoens (with cable) and no accessories.

Share this post


Link to post
Share on other sites
After sending in just the amp and headphones, without cables, they sent me back the amp and new headphoens (with cable) and no accessories.

Sounds fair. :)

No squealing anymore?

Share this post


Link to post
Share on other sites
After sending in just the amp and headphones, without cables, they sent me back the amp and new headphoens (with cable) and no accessories.

Good good :) I emailed them but haven't heard back. I think I may call instead....

Share this post


Link to post
Share on other sites

Mine never squealed, my amp had a channel imbalance, and my headband was bent when I got it, so I just sent them in for a refresh.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...